#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(ab\w*d)$"
Local $sString = "abdskfjhfdkjghrehd" & @CRLF & _
"abueekjkfjdkfjd" & @CRLF & _
"abd" & @CRLF & _
"abksadjlksdfjkldfsjde" & @CRLF & _
"ajsdlkdsjflksdfjdde"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")