package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(ab\w*d)$`)
var str = `abdskfjhfdkjghrehd
abueekjkfjdkfjd
abd
abksadjlksdfjkldfsjde
ajsdlkdsjflksdfjdde`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}