$re = '/^(ab\w*d)$/mi';
$str = 'abdskfjhfdkjghrehd
abueekjkfjdkfjd
abd
abksadjlksdfjkldfsjde
ajsdlkdsjflksdfjdde';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);