#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^.*(From:|Sent:|Sent\s+From|To:|Subj|Dear\s+(Sir|Madam)|http).*$"
Local $sString = " From: <Name>" & @CRLF & _
" Sent: <Datetime>" & @CRLF & _
" To: <Name>" & @CRLF & _
" Subj Dear Sir/Madam" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Hi Vaibhav," & @CRLF & _
"" & @CRLF & _
"Hope you are doing well." & @CRLF & _
"" & @CRLF & _
"http://developer.android.com/sdk/index.html" & @CRLF & _
"" & @CRLF & _
"Sent from my Windows 10 phone"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)