using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"lednet(.*)\.exe";
string input = @"lednet 1043.exe
lednet 1045.exe
lednet.exe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}