$re = '/lednet(.*)\.exe/m';
$str = 'lednet 1043.exe
lednet 1045.exe
lednet.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);