#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^A\r\n]*+(?>A[^A\r\n]*)*?Ap oS.*"
Local $sString = "xxv jkAxxxxxxxxxxxxxx xxyu xxxxxxAxxxxxxxx xxxxxxxxxxxxxxxxxxxxxAp oSxx" & @CRLF & _
"ppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppp" & @CRLF & _
"ppdfldsfkldskflklksdflklskdlfklksdfsdlfkldsfAps" & @CRLF & _
"xxAp oSxxxxxxxxxxxxAp oSxxxxj xxxxxxxxxuixxxxxxxxxxx axxxxxxxxxAp oSxxxx" & @CRLF & _
"tyAtjlA ioA567A pfA pfA pfA pfA yhA pfA pfAthuA pfA koAeftA pfA pfAtuA A "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")