$re = '/^[^A\r\n]*+(?>A[^A\r\n]*)*?Ap oS.*/m';
$str = 'xxv jkAxxxxxxxxxxxxxx xxyu xxxxxxAxxxxxxxx xxxxxxxxxxxxxxxxxxxxxAp oSxx
ppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppp
ppdfldsfkldskflklksdflklskdlfklksdfsdlfkldsfAps
xxAp oSxxxxxxxxxxxxAp oSxxxxj xxxxxxxxxuixxxxxxxxxxx axxxxxxxxxAp oSxxxx
tyAtjlA ioA567A pfA pfA pfA pfA yhA pfA pfAthuA pfA koAeftA pfA pfAtuA A ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);