import Foundation
let pattern = #"^[^A\r\n]*+(?>A[^A\r\n]*)*?Ap oS.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
xxv jkAxxxxxxxxxxxxxx xxyu xxxxxxAxxxxxxxx xxxxxxxxxxxxxxxxxxxxxAp oSxx
ppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppp
ppdfldsfkldskflklksdflklskdlfklksdfsdlfkldsfAps
xxAp oSxxxxxxxxxxxxAp oSxxxxj xxxxxxxxxuixxxxxxxxxxx axxxxxxxxxAp oSxxxx
tyAtjlA ioA567A pfA pfA pfA pfA yhA pfA pfAthuA pfA koAeftA pfA pfAtuA A
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)