package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[A-Za-z]+\d*(?: [A-Za-z]+\d*)*`)
var str = `Hyderabad RTC K1 1991-1998
Hyderabad RTC KK 1876-1897
Al Test K5 1876-9876`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}