re = /^[A-Za-z]+\d*(?: [A-Za-z]+\d*)*/mi
str = 'Hyderabad RTC K1 1991-1998
Hyderabad RTC KK 1876-1897
Al Test K5 1876-9876'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end