import re
regex = re.compile(r"^[A-Za-z]+\d*(?: [A-Za-z]+\d*)*", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Hyderabad RTC K1 1991-1998\n"
"Hyderabad RTC KK 1876-1897\n"
"Al Test K5 1876-9876")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")