$re = '@^(?:https?://)?([^/]+)@m';
$str = 'www.example.com/
https://example.com/
example.com
example.com/boo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);