$re = '/\b(?:[^dClv\s]*[dClv]){4}[^dClv\s]*\b/mi';
$str = 'lcvd, LcVd, aaaadclv44444
daClv or daCalav
aaaadclv44444c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);