import re
regex = re.compile(r"\b(?:[^dClv\s]*[dClv]){4}[^dClv\s]*\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("lcvd, LcVd, aaaadclv44444\n\n"
"daClv or daCalav\n\n\n"
"aaaadclv44444c")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")