re = /\b(?:[^dClv\s]*[dClv]){4}[^dClv\s]*\b/mi
str = 'lcvd, LcVd, aaaadclv44444
daClv or daCalav
aaaadclv44444c'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end