package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^https?://dns.domain.tld\/?(\?.*)?$`)
var str = `http://dns.domain.tld/?foo=bar`
var substitution = "https://dns.domain.tld/dns-query$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}