re = /^https?:\/\/dns.domain.tld\/?(\?.*)?$/
str = 'http://dns.domain.tld/?foo=bar'
subst = 'https://dns.domain.tld/dns-query$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result