const regex = new RegExp('^https?://dns.domain.tld\\/?(\\?.*)?$', 'g')
const str = `http://dns.domain.tld/?foo=bar`;
const subst = `https://dns.domain.tld/dns-query$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);