import re
regex = re.compile(r"(.*)", flags=re.MULTILINE)
test_str = ("HIT & REPLACE\n"
"11/21/1994\n"
"12/11/2014\n"
"03/31/2016 # Hit only if unchecked for length months/days\n\n"
"NO-HIT\n"
"11//12/2090\n"
"37/14/2015\n"
"20/27/2011\n"
"10/32/1964\n"
"14/03/2020\n\n"
"HINTS\n"
"- Use g-flag only.\n")
subst = "$1,$1,$1"
result = regex.sub(subst, test_str)
if result:
print(result)