#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Z]\d|\d[A-Z])+$"
Local $sString = "D1B2C4Q3" & @CRLF & _
"D1B2C433" & @CRLF & _
"D1B2C4Q3" & @CRLF & _
"DDA1Q3" & @CRLF & _
"D$1A2B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")