package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Z]\d|\d[A-Z])+$`)
var str = `D1B2C4Q3
D1B2C433
D1B2C4Q3
DDA1Q3
D$1A2B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}