$re = '/^(?:[A-Z]\d|\d[A-Z])+$/m';
$str = 'D1B2C4Q3
D1B2C433
D1B2C4Q3
DDA1Q3
D$1A2B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);