const regex = /\d{1,4}[A-Za-z]|\/?\d{1,4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,4}[A-Za-z]|\\\/?\\d{1,4}', 'gm')
const str = `Streets numbers:
/1
78
3a
89/
-1 (special case)
1
Apartment:
1-
2-5
12
7a
3a
Aadresses for testing:
Põllu tn 3-1-
Joa tn 3a-1-3
Kapa vkt 78
Kivimäe/1
Aia tn 11/2-5
Männiku tee 89/1-438, Nõmme linnaosa, Tallinn, Harju maakond
Männiku pst
Männiku mnt 12345
1. Mai tn
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}