// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,4}[A-Za-z]|\/?\d{1,4}").unwrap();
let string = "Streets numbers:
/1
78
3a
89/
-1 (special case)
1
Apartment:
1-
2-5
12
7a
3a
Aadresses for testing:
Põllu tn 3-1-
Joa tn 3a-1-3
Kapa vkt 78
Kivimäe/1
Aia tn 11/2-5
Männiku tee 89/1-438, Nõmme linnaosa, Tallinn, Harju maakond
Männiku pst
Männiku mnt 12345
1. Mai tn
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}