use strict;
my $str = 'Streets numbers:
/1
78
3a
89/
-1 (special case)
1
Apartment:
1-
2-5
12
7a
3a
Aadresses for testing:
Põllu tn 3-1-
Joa tn 3a-1-3
Kapa vkt 78
Kivimäe/1
Aia tn 11/2-5
Männiku tee 89/1-438, Nõmme linnaosa, Tallinn, Harju maakond
Männiku pst
Männiku mnt 12345
1. Mai tn
';
my $regex = qr/\d{1,4}[A-Za-z]|\/?\d{1,4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}