#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{1,4}[A-Za-z]|\/?\d{1,4})"
Local $sString = "Streets numbers:" & @CRLF & _
"/1" & @CRLF & _
"78" & @CRLF & _
"3a" & @CRLF & _
"89/" & @CRLF & _
"-1 (special case)" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"Apartment:" & @CRLF & _
"1-" & @CRLF & _
"2-5" & @CRLF & _
"12" & @CRLF & _
"7a" & @CRLF & _
"3a" & @CRLF & _
"" & @CRLF & _
"Aadresses for testing:" & @CRLF & _
"Põllu tn 3-1-" & @CRLF & _
"Joa tn 3a-1-3" & @CRLF & _
"Kapa vkt 78" & @CRLF & _
"Kivimäe/1" & @CRLF & _
"Aia tn 11/2-5" & @CRLF & _
"Männiku tee 89/1-438, Nõmme linnaosa, Tallinn, Harju maakond" & @CRLF & _
"Männiku pst" & @CRLF & _
"Männiku mnt 12345" & @CRLF & _
"1. Mai tn" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")