import Foundation
let pattern = #"^(?:\d{1,4}[A-Za-z]|\/?\d{1,4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Streets numbers:
/1
78
3a
89/
-1 (special case)
1
Apartment:
1-
2-5
12
7a
3a
Aadresses for testing:
Põllu tn 3-1-
Joa tn 3a-1-3
Kapa vkt 78
Kivimäe/1
Aia tn 11/2-5
Männiku tee 89/1-438, Nõmme linnaosa, Tallinn, Harju maakond
Männiku pst
Männiku mnt 12345
1. Mai tn
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)