# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\d{1,4}[A-Za-z]|\/?\d{1,4})"
test_str = ("Streets numbers:\n"
"/1\n"
"78\n"
"3a\n"
"89/\n"
"-1 (special case)\n"
"1\n\n"
"Apartment:\n"
"1-\n"
"2-5\n"
"12\n"
"7a\n"
"3a\n\n"
"Aadresses for testing:\n"
"Põllu tn 3-1-\n"
"Joa tn 3a-1-3\n"
"Kapa vkt 78\n"
"Kivimäe/1\n"
"Aia tn 11/2-5\n"
"Männiku tee 89/1-438, Nõmme linnaosa, Tallinn, Harju maakond\n"
"Männiku pst\n"
"Männiku mnt 12345\n"
"1. Mai tn\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.