import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Vuln : Upgrade\\s*(?<vulnNameFromTo>.*?)\\s+from\\s+(?<vulnCurrentVersionFromTo>.*?)\\s+to\\s+(?<vulnFixVersionFromTo>.+?)(?:\\s+for\\b.*)?$";
final String string = "Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final\n"
+ "Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final for github.com/blah/blah\n\n"
+ "I specifically just need to grab the strings pypi://onnx 1.12.0 1.13.0 Final.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}