const regex = /Vuln : Upgrade\s*(?<vulnNameFromTo>.*?)\s+from\s+(?<vulnCurrentVersionFromTo>.*?)\s+to\s+(?<vulnFixVersionFromTo>.+?)(?:\s+for\b.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Vuln : Upgrade\\s*(?<vulnNameFromTo>.*?)\\s+from\\s+(?<vulnCurrentVersionFromTo>.*?)\\s+to\\s+(?<vulnFixVersionFromTo>.+?)(?:\\s+for\\b.*)?$', 'gm')
const str = `Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final
Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final for github.com/blah/blah
I specifically just need to grab the strings pypi://onnx 1.12.0 1.13.0 Final.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}