re = /Vuln : Upgrade\s*(?<vulnNameFromTo>.*?)\s+from\s+(?<vulnCurrentVersionFromTo>.*?)\s+to\s+(?<vulnFixVersionFromTo>.+?)(?:\s+for\b.*)?$/m
str = 'Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final
Vuln : Upgrade pypi://onnx from 1.12.0 to 1.13.0 Final for github.com/blah/blah
I specifically just need to grab the strings pypi://onnx 1.12.0 1.13.0 Final.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end