import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<date>(\\[|)(\\d{4}-\\d{2}-\\d{2}(T| )\\d{2}:\\d{2}:\\d{2}(\\]|.+\\d{2}:\\d{2}\\]|.+\\d{2}:\\d{2})))(?<message>.*?)$";
final String string = "[2022-10-31 10:16:22] main.ERROR: The \"--only-trace\" option does not exist.\n"
+ "#0 /var/www/magento/vendor/symfony/console/Input/ArgvInput.php(143): Symfony\\Component\\Console\\Input\\ArgvInput->addLongOption('only-trace', 'test')\n"
+ "#1 /var/www/magento/vendor/symfony/console/Input/ArgvInput.php(79): Symfony\\Component\\Console\\Input\\ArgvInput->parseLongOption('--only-trace=te...')\n"
+ "#2 /var/www/magento/vendor/symfony/console/Input/Input.php(55): Symfony\\Component\\Console\\Input\\ArgvInput->parse()\n"
+ "[2022-10-31 10:16:22] main.ERROR: I'm a new group";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}