$re = '/^(?<date>(\[|)(\d{4}-\d{2}-\d{2}(T| )\d{2}:\d{2}:\d{2}(\]|.+\d{2}:\d{2}\]|.+\d{2}:\d{2})))(?<message>.*?)$/sm';
$str = '[2022-10-31 10:16:22] main.ERROR: The "--only-trace" option does not exist.
#0 /var/www/magento/vendor/symfony/console/Input/ArgvInput.php(143): Symfony\\Component\\Console\\Input\\ArgvInput->addLongOption(\'only-trace\', \'test\')
#1 /var/www/magento/vendor/symfony/console/Input/ArgvInput.php(79): Symfony\\Component\\Console\\Input\\ArgvInput->parseLongOption(\'--only-trace=te...\')
#2 /var/www/magento/vendor/symfony/console/Input/Input.php(55): Symfony\\Component\\Console\\Input\\ArgvInput->parse()
[2022-10-31 10:16:22] main.ERROR: I\'m a new group';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);