package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<key>\w+)=(?P<value>\w+)`)
var str = `&{dict1_name}= key1=key1value key2=key2value
&{dict2_name}= key1=key1value`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}