re = /(?P<key>\w+)=(?P<value>\w+)/m
str = '&{dict1_name}= key1=key1value key2=key2value
&{dict2_name}= key1=key1value'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end