$re = '/(?P<key>\w+)=(?P<value>\w+)/m';
$str = '&{dict1_name}= key1=key1value key2=key2value
&{dict2_name}= key1=key1value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);