using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^----[- ](?:BEGIN|END) (?:([A-Z][A-Z0-9]+) )?(PRIVATE|PUBLIC) KEY[ -]----$";
string input = @"PKCS#1
-----BEGIN RSA PRIVATE KEY-----
-----END RSA PRIVATE KEY-----
-----BEGIN RSA PUBLIC KEY-----
-----END RSA PUBLIC KEY-----
PKCS#8
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
-----BEGIN ENCRYPTED PRIVATE KEY-----
-----END ENCRYPTED PRIVATE KEY-----
-----BEGIN PUBLIC KEY-----
-----END PUBLIC KEY-----
-----BEGIN DSA PRIVATE KEY-----
-----END DSA PRIVATE KEY-----
-----BEGIN DSA PUBLIC KEY-----
-----END DSA PUBLIC KEY-----
SSH2
---- BEGIN SSH2 PUBLIC KEY ----
---- END SSH2 PUBLIC KEY ----";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}