$re = '/^----[- ](?:BEGIN|END) (?:([A-Z][A-Z0-9]+) )?(PRIVATE|PUBLIC) KEY[ -]----$/m';
$str = 'PKCS#1
-----BEGIN RSA PRIVATE KEY-----
-----END RSA PRIVATE KEY-----
-----BEGIN RSA PUBLIC KEY-----
-----END RSA PUBLIC KEY-----
PKCS#8
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
-----BEGIN ENCRYPTED PRIVATE KEY-----
-----END ENCRYPTED PRIVATE KEY-----
-----BEGIN PUBLIC KEY-----
-----END PUBLIC KEY-----
-----BEGIN DSA PRIVATE KEY-----
-----END DSA PRIVATE KEY-----
-----BEGIN DSA PUBLIC KEY-----
-----END DSA PUBLIC KEY-----
SSH2
---- BEGIN SSH2 PUBLIC KEY ----
---- END SSH2 PUBLIC KEY ----';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);