import re
regex = re.compile(r"^----[- ](?:BEGIN|END) (?:([A-Z][A-Z0-9]+) )?(PRIVATE|PUBLIC) KEY[ -]----$", flags=re.MULTILINE)
test_str = ("PKCS#1\n"
"-----BEGIN RSA PRIVATE KEY-----\n"
"-----END RSA PRIVATE KEY-----\n"
"-----BEGIN RSA PUBLIC KEY-----\n"
"-----END RSA PUBLIC KEY-----\n\n"
"PKCS#8\n"
"-----BEGIN PRIVATE KEY-----\n"
"-----END PRIVATE KEY-----\n"
"-----BEGIN ENCRYPTED PRIVATE KEY-----\n"
"-----END ENCRYPTED PRIVATE KEY-----\n"
"-----BEGIN PUBLIC KEY-----\n"
"-----END PUBLIC KEY-----\n\n"
"-----BEGIN DSA PRIVATE KEY-----\n"
"-----END DSA PRIVATE KEY-----\n"
"-----BEGIN DSA PUBLIC KEY-----\n"
"-----END DSA PUBLIC KEY-----\n\n"
"SSH2\n"
"---- BEGIN SSH2 PUBLIC KEY ----\n"
"---- END SSH2 PUBLIC KEY ----")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")