import re
regex = re.compile(r"\[\*\*]([^[]*(?:\[(?!/?\*\*])[^[]*)*)\[/\*\*]")
test_str = ("[table]\n"
"[**]header1[||]header2[||]header3[||]...[/**]\n"
"[*]child1.1[|]child1.2[|]child1.3[|]...\n"
"[*]child2.1[|]child2.2[|]child2.3[|]...\n"
"[*]child3.1[|]child3.2[|]child3.3[|]...\n"
"[*]...[|]...[|]...[|]...\n"
"[/table]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")