re = /\[\*\*]([^[]*(?:\[(?!\/?\*\*])[^[]*)*)\[\/\*\*]/
str = '[table]
[**]header1[||]header2[||]header3[||]...[/**]
[*]child1.1[|]child1.2[|]child1.3[|]...
[*]child2.1[|]child2.2[|]child2.3[|]...
[*]child3.1[|]child3.2[|]child3.3[|]...
[*]...[|]...[|]...[|]...
[/table]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end