package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)>\s*(.*?)\s*</div>`)
var str = `XXX='<div class="document-published-date">
July 14, 2018
</div>'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}