$re = '/(?s)>\s*(.*?)\s*</div>/m';
$str = 'XXX=\'<div class="document-published-date">
July 14, 2018
</div>\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);