re = /(?s)>\s*(.*?)\s*<\/div>/m
str = 'XXX=\'<div class="document-published-date">
July 14, 2018
</div>\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end