using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^is(?<subdomain_suffix>.+?)\.site\.com$";
string input = @"isa.site.com
isb.site.com
isa.site.comb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}