$re = '~^is(?<subdomain_suffix>.+?)\.site\.com$~m';
$str = 'isa.site.com
isb.site.com
isa.site.comb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);