re = /^is(?<subdomain_suffix>.+?)\.site\.com$/m
str = 'isa.site.com
isb.site.com
isa.site.comb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end