#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w*[a-zA-Z]\w*)"
Local $sString = "abcde" & @CRLF & _
"a012ds" & @CRLF & _
"adas31" & @CRLF & _
"1313a" & @CRLF & _
"a3141" & @CRLF & _
"a" & @CRLF & _
"313141"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")