$re = '/(\w*[a-zA-Z]\w*)/m';
$str = 'abcde
a012ds
adas31
1313a
a3141
a
313141';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);